补充:一些系统,例如ubuntu,在安装git,或者编译的时候会出错,有可能是你在手动编译安装git的时候,没有安装依赖包,在安装依赖包的时候没有成功,而失败,你自己没有注意,解决方法如下(ubuntu):
apt install git-all
apt-get install dh-autoreconf libcurl4-gnutls-dev libexpat1-dev
gettext libz-dev libssl-dev
apt-get install golang
参考:
https://git-scm.com/book/zh/v2/%E8%B5%B7%E6%AD%A5-%E5%AE%89%E8%A3%85-Git
https://blog.csdn.net/fenggms/article/details/83051423
https://blog.csdn.net/zhezhebie/article/details/78035979
https://blog.csdn.net/tonyfreak/article/details/80016577